vems config for no cam inverter setup

Discuss VEMS and other standalone ECUs

vems config for no cam inverter setup

Postby diesel des » Wed Jun 22, 2016 3:29 am

So I have a urq project running a 20vt aan setup with aby loom etc. I have just built the car and new stroker engine on 1200 cc injectors and big turbo etc so I had lots of things that could be incorrect. To make sure the vems was ok I sent it for test and repair and it took over 6 weeks. I asked for a test and a description of each input so I new what I had and what I would need to connect extra parts like anti lag and multi fuel etc. Anyhow it came back with some written details like the air temperature sensor is ntc not pct and no cam inverter. Anyhow it did have no trigger errors during cranking and while testing it did fire each injector and spark. But the car would not start after 2 days testing and work. I tried everything I knew. The car would only pop and bang like a car with plug leads on wrong. I was using the config that came from vems in the ecu. I tried changing lots of things. So I took a day off work and removed the vems ecu from my audi urs4 . I just changed the required fuel to suit the bigger injectors and boom the urq started first try. So my engine is good. My wiring is good. Its my tested vems that is wrong. As it has no cam inverter I think my problem is with the settings for telling the ecu were tdc is. So what crank refrence settings do I need and what else do I need to change on an ecu with no cam inverter? Any get me started maps for vems on a new firmware with no cam invert and 1000 to 1200 cc injectors?

Thanks des
diesel des
 
Posts: 11
Joined: Aug 1, 2013

Re: vems config for no cam inverter setup

Postby Marc » Thu Jun 30, 2016 10:06 pm

I have that info here somewhere, I'll try and dig it up for you tomorrow.

in the mean time, it is possible to convert a non cam hall inverter ecu to a inverter ecu externally with a cable wired in-line with the cam sensor. diagram here:

Image

I have one built in stock I can sell you for a modest amount if needed.
Marc Swanson
Proprietor, EFI Express

Image
Marc
 
Posts: 1563
Joined: Feb 27, 2013

Re: vems config for no cam inverter setup

Postby diesel des » Fri Jul 01, 2016 12:57 am

Thanks Marc. Just yesterday I had a company I used to work for build me an inverter which will go inline with the cam sensor. Its a diffrent circuit they used but I will report back how I get on. Wish I had of just bought a new ecu now...
diesel des
 
Posts: 11
Joined: Aug 1, 2013

Re: vems config for no cam inverter setup

Postby diesel des » Sun Jul 03, 2016 5:41 pm

Marc, the inverter worked fine. Car now running on the ecu with no trigger errors but i do have problems with the wide band lambda. I will start a new thread. I would really appreciate it if you could have a look at it for me. Cheers.
diesel des
 
Posts: 11
Joined: Aug 1, 2013


Return to Standalone Engine Management

Who is online

Users browsing this forum: No registered users and 2 guests

cron