Page 1 of 1

A4 2.0t heat issue

PostPosted: Thu Mar 07, 2019 1:03 pm
by nmerrill
Folks,
wondering if someone here might have any thoughts on this issue with the wifes A4 2.0T...

It was producing low heat output - engine temp normal. On the road, the heat was minimal, at idle, almost non-existent.
I have now flushed and bled the heater core three times.
Each time, the heat has returned to normal output, but days/week later, it stops heating!

I never had much crap come out during the flushes, maybe a few little bits of scale.

I want to go back now and check that there is not a new air bubble at the heater core, and I can't recall if I have checked that before.

I'm wondering if crap could be flowing out of the rest of the system, and re-clogging the core?
The car has had several coolant changes - that is, I don't expect that it is all scaled up, but maybe I'm wrong.

Thoughts?
Nat

Re: A4 2.0t heat issue

PostPosted: Thu Mar 07, 2019 1:56 pm
by MikeB25
My experience is only with the 1.8T in a B6 but the symptoms were very similar. Multiple flushings never helped much. I finally bit the bullet and put in a new heater core last winter and the heat is still amazing a year+ later. The old heater core didn't seem plugged up and nothing much came out of it when I tried flushing it on the bench but maybe it was packed solid. Be sure to follow the bleed process after installing the new core.

Re: A4 2.0t heat issue

PostPosted: Fri Mar 08, 2019 1:55 am
by alxdgr8
The B7 2.0t thermostats are very common failure points. Replace with OE, it's not too difficult to do. Sometimes it's hard to tell with their gauges if they are fully warmed up or not. Had that issue on my wife's B7 when we bought it and thermostat fixed it. But don't cheap out as the aftermarket ones don't last long.

Sent from my Pixel 3 XL using Tapatalk

Re: A4 2.0t heat issue

PostPosted: Fri Mar 08, 2019 1:56 am
by alxdgr8
The flushing behavior does seem to point to heater core though.

Sent from my Pixel 3 XL using Tapatalk

Re: A4 2.0t heat issue

PostPosted: Fri Mar 08, 2019 8:54 pm
by nmerrill
Yea, that fact that flushing it fixes it temporarily is confusing, and has me thinking about floating crap from elsewhere in the system.

Re: A4 2.0t heat issue

PostPosted: Sat Mar 09, 2019 1:30 am
by TCombs
Does it blow out normally? Like its blowing out air but the air isnt warm?

Re: A4 2.0t heat issue

PostPosted: Sat Mar 09, 2019 9:44 am
by nmerrill
yes, the air circulates as normal it seems - changes output locations appropriately, etc.
I hooked up Vagcom and had no issues noted with controls either